Jump to content

RMM+ Passwords: A password syncing tool for ScreenConnect and Labtech


Recommended Posts

3 minutes ago, iniguezsal said:

this is what is logged when I try logging in. Not sure what the 5th line means. 

10/02/2020 9:03 AM - RMMPasswords - DEBUG: ProcessCallbackData2
10/02/2020 9:03 AM - RMMPasswords - DEBUG: MFA (DownloadURL) SERVER: localhost
10/02/2020 9:03 AM - RMMPasswords - DEBUG: Called MFA code request
10/02/2020 9:03 AM - RMMPasswords - DEBUG: START postData
10/02/2020 9:03 AM - RMMPasswords - DEBUG: Object reference not set to an instance of an object.
10/02/2020 9:03 AM - RMMPasswords - DEBUG: FINISH postData

MFA (DownloadURL) SERVER: localhost

NOTE: If you are having issues logging in and getting blank screen when trying to login verify DownloadURL value in the config table and make sure it is the same as your server so if your login Automate URL is https://rmm.domain.com DownloadURL should be rmm.domain.com.

Check your DownloadURL in the DB config table. It should be the same as the server url....typically https://automate.domain.com or something like that.

 

Link to post
Share on other sites
  • Replies 218
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Please try to donate if you can. A lot of time went into this plugin - DOWNLOAD HERE Thank you to my donors: Mendy Green Gavin Stone Matt Navarette ITLogix, LLC Derek Lei

Your wish is my command 1.0.0.9 - Added auditing of passwords sent, passwords copied and scripts sent to the Dashboard Audit section!

Please note that version 1.0.22 of the control extension is waiting to be approve. When you upgrade make sure you add your Automate url in the extension settings as it is now hard coded there instead

Posted Images

42 minutes ago, iniguezsal said:

this is what is logged when I try logging in. Not sure what the 5th line means. 

10/02/2020 9:03 AM - RMMPasswords - DEBUG: ProcessCallbackData2
10/02/2020 9:03 AM - RMMPasswords - DEBUG: MFA (DownloadURL) SERVER: localhost
10/02/2020 9:03 AM - RMMPasswords - DEBUG: Called MFA code request
10/02/2020 9:03 AM - RMMPasswords - DEBUG: START postData
10/02/2020 9:03 AM - RMMPasswords - DEBUG: Object reference not set to an instance of an object.
10/02/2020 9:03 AM - RMMPasswords - DEBUG: FINISH postData

I got it working again. It was the config table. Thank you apbirch67

Link to post
Share on other sites

On the front page you have a note saying that the Control plugin needs to be 1.0.32+ to work with the latest Control updates, but Control's extension update check keeps saying 1.0.31 is the latest and up-to-date.  Do you know when we might expect to see 1.0.32 available?

Link to post
Share on other sites

Yup, was able to update.  Thanks for that!

However now I am getting the blank screen on login.  If I click away from Passwords and click back, it reports "Token Error: Token Issue".  If I check "Enable Debugging" on login it instead gives me a white window that just says "undefined".  If I leave off the MFA it does prompt for MFA so it is definitely communicating properly.  I verified DownloadURL to be correct in Automate's config table.  I'm not seeing a C:\Windows\Temp\ logfile, or one in %Temp%.  Any suggestions on troubleshooting?

Link to post
Share on other sites
  • 1 month later...

Is there anymore documentation around the "AllowedOrigin" setting and what it is used for? Should it be set to the Automate server address?

I am using the current version of RMM+ for both Control and Automate and everything seems to be working as per normal.

Link to post
Share on other sites

AllowedOrigin can be set to anything you want it just has to be the same on both the control and automate plugins. If it is not set the only thing that doesn't work is sending commands from the plugin so if you don't do that you will not even notice a difference if not set.

Link to post
Share on other sites

Note you need to update to 1.0.0.33 version of the automate plugin before moving to Automate 21 as there is new password hashing for users so the logic needed a change. The 1.0.0.33 will remain backwards compatible with 20 so it can be installed any time.

Link to post
Share on other sites
54 minutes ago, Michael Frice said:

I upgraded Automate to 2021 last night and now I can't log into the RMM+ extension. I am a little confused as to where the new configuration changes need to happen. Is there any documentation on the updated version settings?

You need to download the latest automate update here

http://bigdessert.com/rmm/rmm-password.html

Then make sure you control plugin is up to date.

Link to post
Share on other sites

We use hosted automate and had been using this plugin for awhile, but it stopped working today.

I updated both the Control Extension to 1.0.33 and the Automate plugin to 1.0.0.32, restarted DB Agent and Restarted IIS and it's still not working for us.

When I try to log into the plugin in Control I get 'password Invalid' error, even though I know the password is correct as I can log in directly to our hosted Automate server using the same info.

2FA is enabled on Automate, and that works correctly directly on the server as well, but I can't seem to get it to accept my password in the first place.

I tried to look for a log file like mentioned above but I don't seem to have that in C:\Windows\Temp\

Any suggestions for why this isn't working for us anymore?

Just let us know, thanks!

 

-Tyler

 

Link to post
Share on other sites

There are a couple of control buttons available in the 'Server Status' window in Control Center for hosted Automate, but maybe I was mistaken and none of them do an actual IISreset.

Maybe this is something Automate Support could do for me, but they tend to balk at these kinds of requests.
image.thumb.png.d8d05dc8d5e595f285b37019a221c336.png
 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...